Kameraansicht bewegt sich mit der Maus zu schnell

  • Hallo,


    ich habe leider ein merkwürdiges Problem mit der Kamerasteuerung.
    Gemeint ist die Steuerung wenn man die rechte Maustaste gedrückt hält und dann die Ansicht mit der Maus verändert.
    Die ist extrem schnell, kleinste Bewegungen führen zu extremen Veränderungen.
    Komischerweise war das vorher nicht so, kam irgendwie plötzlich.


    Kann man das in den Einstellungen anpassen und wenn ja welcher Regler ist es? Oder könnte das ein Bug sein? Es ist wirklich so schnell, das ich es nicht mehr gebrauchen kann.
    Mit den Pfeiltasten auf der Tastatur bewegt sich die Kamera noch normal.

  • Schau mal in den Wikiartikel Optionen (https://www.kerbalspaceprogram…hp?page=LexiconItem&id=88).
    Da wurden zumindest die Optionen übersetzt, die in 0.21 enthalten waren.
    Aber ich glaube du kannst die Mausempfindlichkeit nicht direkt in KSP einstellen.


    Steuert denn deine Maus generell schneller oder nur wenn du die rechte Maustaste gedrückt hältst? Wenn ja, dann schau dir doch mal die DPI Einstellungen deiner Maus an. Vielleicht haben die sich ja irgendwie verstellt.

    Für den Triumph des Bösen reicht es, wenn das Gute nichts unternimmt.

  • Leider finde ich dort keine passende Maus Einstellung.


    Mir ist etwas aufgefallen. Die Bewegung der Kamera ist nicht nur einfach schnell, sondern erfolgt in einem Raster.
    Also die Kamera springt bzw. gleitet von Punkt zu Punkt in einem groben unsichtbaren Raster. Man kann die Ansicht quasi nicht zwischen zwei Punkten des Rasters positionieren.
    Maus Einstellungen am Betriebssystem bezüglich Sensibilität führten zu keiner Veränderung.


    Die Mausgeschwindigkeit ist im Spiel ganz normal, nur bei gedrückter rechter Maustaste ist es so schnell bzw. erfolgt in einem Raster :huh:


    Ich habe KSP auf Linux mit Steam, dort habe ich das Problem.
    KSP mit Steam auf Windows macht keine solchen Probleme, dort bewegt sich die Ansicht flüssig und langsam und nicht ruckartig von Rasterpunkt zu Rasterpunkt.


    Echt schade, dabei hatte ich mich gefreut KSP auf Linux spielen zu können, aber so ist es einfach nur ätzend, ich mag nicht die Pfeiltasten der Tastatur benutzen für die Kamera.


    Auf Linux spinnt übrigens auch die Demo von KSP. Beim bauen einer Rakete gibt es kein Snapping, man kann die Raketenteile nicht miteinander verbinden. Auf Windows läuft die Demo problemlos :(

  • Na damit kann man ja schon mal paar Suchanfragen bei Google starten und das Problem immerhin beschreiben.


    Zack, fündig geworden: http://steamcommunity.com/app/…974467288867445/?l=german


    Das Wichtigste:


    The mouse sensitivity slider in the settings menu doesn't do anything in my case.


    What worked for me is editiing the settings.cfg file in Steam/SteamApps/common/Kerbal Space Program/


    I set those to 0.25:
    VAB_CAMERA_ORBIT_SENS
    VAB_CAMERA_ZOOM_SENS
    FLT_CAMERA_ORBIT_SENS
    FLT_CAMERA_ZOOM_SENS


    And I set the sensitivity of all those to 0.25
    AXIS_CAMERA_HDG
    AXIS_CAMERA_PITCH
    AXIS_MOUSEWHEEL


    -.MfG Etorofu.-

  • Uff, da wird es auch mir zu speziell. Habe selber ungefähr so viel Ahnung von Linux wie die Kuh vom Kessler-Syndrom.
    Habe ja gehofft, das würde dir helfen, da es auch so einfach klang. Mal eben locker flockig ne .cfg ändern.. als Windows-User kennt man das ja. ^^


    Kannst du da bei Linux nicht auch den Schreibschutz für eine Datei aktivieren?


    Dann könntest du den Wert wie beschrieben auf 0.25 ändern, speicherst ab und aktivierst den Schreibschutz für diese Datei. Dann dürfte der selbst bei einem Spielstart den Wert nicht ändern - zumindest hoffe ich das für dich!


    -.MfG Etorofu.-

  • Ich habs geschafft! :thumbsup:


    Hier habe ich gelesen das es in KSP Fehler gibt was die Behandlung von Kommas angeht:
    http://forum.kerbalspaceprogra…38&viewfull=1#post1100738


    Deswegen wurden die Werte in der Datei wohl auf 25 gestellt weil der mit dem Komma nicht klar kam.
    Wenn man KSP mit dem Konsolen Befehl LC_ALL=C ./KSP.x86_64 startet also die globale Variable LC_ALL=C davor setzen, dann bleiben die Werte bei 0.25 und tatsächlich hat das geholfen.


    Danke! Gab hier wertvolle Hinweise :)

  • Noch eine Ergänzung. Möchte man KSP lieber über Steam starten statt über die Konsole, dann geht man in die Eigenschaften von KSP in der Steam Spieleliste und gibt unter "Startoptionen festlegen..." das ein: LC_ALL=C %command%_64
    Dann startet es genau wie mit der Konsole und der LC_ALL Option.