KSP sagt gar nichts mehr...

  • Ich bin ein geduldiger Mensch aber langsam treibt mich KSP in den Wahnsinn.
    Folgendes Problem: Ich habe bisher in der 0.24.2 mit einem haufen Mods annähernd problemlos gespielt. Dann habe ich B9 neu runtergeladen weil ich nicht genau wusste ob es noch die aktuellste Version war und einen Modmanager, damit alles etwas mehr Ordnung bekommt.
    Jetzt läuft der Ladebalken bei der 32- sowie 64-Bit Version normal durch, der Modulmanager macht was er eben so macht und es bleibt stehen....
    Da es anfangs immer bei einem B9 Cockpit hängen geblieben ist, dachte ich das es an B9 liegt und habe es einfach mal gelöscht.
    Da das Problem immer noch das selbe war (Es hing jetzt nur an einem anderen Teil), habe ich angefangen einzelne Mods zu löschen und es immer wieder neu gestartet.
    Die KSP.exe belegt nach dem Laden etwas mehr als 2 Gb, also alles im grünen bereich. Hamachi habe ich auch nicht drauf.


    Hat sonst noch jemand das selbe Problem bzw. eine Lösung?


    Hier mal eine Liste der Mods:


    B9 R5-2-3
    Deadly Reentry v5.2
    KSP EngineerRedux 0.6.2.9
    EnviromentalVisualEnhancements 7-4
    Ferram Aerospace Research v0.1.4.1.1.a
    KAS 0.4.8
    Kerbal Alarm Clock 2.7.8.2
    Kethane 0.9
    KSP Interstellar v0.11
    KW 2.6c
    RealChute v1.2.3
    RemoteTech v1.4.1
    SPO (Simple Part Organizer) 1.2.1
    Tac Lifesupport 0.9.0.9 pre3
    Texture Replacer 1.7.1
    Trajectories
    ActiveTextureManagement (x64 Release-basic)


    Die einzig neuen Mods sind Kethane und der SPO.

  • Ich hatte dieses Problem auch des öfteren, selbst nachdem ich alle Mods deinstalliert habe! Bei mir hat nur eine komplette Neuinstallation geholfen, danaach alle Mods mit denen es noch lief wieder draufgeklatscht. Es ist keine optimale Lösung, aber immerhin konnte ich KSP wieder spielen, wenn auch nicht mit allen Mods die ich gerne gehabt hätte.

  • Ja, da hilft wohl nur eine Neuinstallation. Versuche aber vorher mal, nur den Squad-Ordner neu zu installieren, vlt. hilft das. Ich vermute ja, dass bei diesem Problem durch irgendwas die KSP-Ressourcen Datei verhunzt wird, und ohne die lädt das Spiel nicht.

    Durch das Lesen dieser Nachricht stimmst du meiner EULA zu.


  • Also zum glück mache ich immer eine Kopie der frischen KSP Version und muss sagen das mich KSP langsam in den Wahnsinn treibt.
    Ich habe es Vanilla gestartet und alles war in OK...Dann habe ich angefangen ein par Mods zu installieren und kurz nach dem Laden, wo sich unten rechts schon die Planeten bewegen stoppt es wieder. Sobald ich raustappe sagt mir Windows es wäre abgestürzt und im Error-Report steht, so weit ich das verstanden habe, dass es am RAM-Verbrauch liegt.


    Error occurred at 2014-10-03_144754.
    D:\Programme\Installations-Ordner\Steam\SteamApps\common\Kerbal Space Program\KSP_x64.exe, run by Nico.
    58% memory in use.
    8155 MB physical memory [3372 MB free].
    16307 MB paging file [10742 MB free].
    8388608 MB user address space [8386255 MB free].
    Write to location 03b60000 caused an access violation.


    Das lustige ist das im Taskmanager steht, die KSP.exe würde etwas mehr als 2 Gb ziehen und bei der 64-Bit Anwendung sollte man ja meinen, es dürfe nicht mehr wegen dem RAM abstürzen...


    Was mich etwas verwirrt ist die Zeile: "Write to location 03b60000 caused an access violation."
    Anscheinend verbietet Windows KSP die RAM-Adresse anzusprechen.



    Edit: Also die ganze Sache als Administrator zu starten hat nichts gebraucht, aber die 32 Bit arbeitet momentan noch problemlos.... O.o

  • Write to location 03b60000 caused an access violation.


    Das lustige ist das im Taskmanager steht, die KSP.exe würde etwas mehr als 2 Gb ziehen und bei der 64-Bit Anwendung sollte man ja meinen, es dürfe nicht mehr wegen dem RAM abstürzen...


    Was mich etwas verwirrt ist die Zeile: "Write to location 03b60000 caused an access violation."
    Anscheinend verbietet Windows KSP die RAM-Adresse anzusprechen.


    Hi,


    ich hatte dasselbe Problem, KSP war kaum noch spielbar. Das einzig was bei mir geholfen hat war die Texturen tiefer zu stellen. Danach funktionierte es super hab auch schon wieder viele Mods drauf.


    So wie es aussieht kann KSP immer noch nicht mehr als 4GB ziehen, auch in der 64 bit Version.


    Glaube kaum es liegt an einem ungültigen Adressbereich.