Ksp Datei lädt nicht mehr

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • Ksp Datei lädt nicht mehr

      Hallo, ich habe ein problem mit meiner wichtigsten KSP Datei. Als ich ein Schiff über den Mun laden wollte ist mein Spiel abgestürzt und als ich es neu gestartet habe stand "ksp object reference not set to an instance of an object" unter der Datei in Rot. Die Funktion "Load" war nicht auswählbar. Dieses Problem konnte aber durch das löschen meiner Minmus Groundbase (Die in keinen zusammenhang stand mit dem Schiff das ich auswählen wollte) aus der Textdatei behoben werden. Jetzt war die "Load" funktion wieder auswählbar. Das Spiel hat auch ein paar Sekunden versucht die datei zu laden, aber dann abgebrochen ohne irgendeine Fehlermeldung zu zeigen. Jetzt bin ich ratlos, was kann ich noch tun? Das Spiel ist nicht gemoddet, den einzigen Mod (Sprachmod) habe ich kurz zuvor wieder entfernt.

      OS: Windows 10 1703 Build 15063.413 Creators Update

      CPU: Intel Core i5 3350P @3.1Ghz

      RAM: 12 GB

      Grafik GTX 750Ti
      Dateien
    • Was du machen kannst: Den Fehler (und somit die relevanten Einträge im Log) reproduzieren.
      Einfach dein altes Savegame wieder in den saves Ordner kopieren, KSP starten und abwarten was passiert.
      Und dann bitte die KSP.log Datei hier hochladen
      I mod, therefore I am

    • Also denkst du da lässt sich nichts mehr machen oder wie?
      Das hab ich nicht geschrieben. Erstmal gehts darum rauszufinden was den Fehler verursacht hat. Dann kann man den Fehler beheben. Nützt ja nix wenn man jetzt das Savegame wiederherstellt und dann der gleiche Fehler wieder auftritt. Irgendwas muss es ja verursacht haben. Wenn du mit Schmerzen zum Arzt gehst kriegste auch nciht einfach nur Schmerzmittel und gehst wieder nach Hause. Erstmal macht der Arzt eine Diagnose anhand des Gesundheitsbildes und verschreibt dir dann passende Medikamente welche nicht die Symptome sondern die Ursache bekämpfen. Heißt: Die Symptome zu bekämpfen behebt nicht die Ursache.
      Alles Käse, oder was?
    • Thomas P. schrieb:

      Einfach dein altes Savegame wieder in den saves Ordner kopieren, KSP starten und abwarten was passiert.
      Da lässt sich glaube ich nichts reproduzieren, da ja mein unbearbeitetes Savegame auch nicht zu laden war bloß das da "ksp object reference not set to an instance of an object" stand. Also kann ich weder das unbearbeitete, noch das bearbeitete laden

      Und wie kann ich das ohne die Log Datei herausfinden was den Fehler verursacht hat bzw. ist das überhaupt möglich?
    • Das ist doch egal. Sobald du KSP versuchst zu starten wird eine Log angelegt und dort auch alles dokumentiert. Selbst wenn dann sofort ein Fehler auftritt. Deswegen wollen wir die ja haben. in der Log kann man dann evtl. auch sehen wann udn wodurch dein genannter fehler verursacht wird.

      Und wie willst du ohne Log herausfinden was den Fehler verursacht hat??? Genau dafür ist eine Log doch da. Wenn es anders ginge wäre eine Log überflüssig und würde gar nicht erst angelegt. Somit ist die Antwort auf deine Frage: nein, anders kann man das nicht herausfinden.

      Weiß aber jetzt gerade nicht warum du mit der Log so ein Problem hast!? Starte einfach KSP, lass den Fehler passieren und er wird sofort in der Log vermerkt. Dann KSP schließen und die Log hochladen. Dann nur noch den Link zur Log hier posten und wir gucken uns das an.

      Es gibt übrigens 2 Logs. Eine, KSP.log oder so heißt sie, ist direkt im KSP-Rootverzeichnis, da wo auch die KSP.exe drin ist. Die ander ist im Ordner KSP64bit oder so ähnlich. Da heißt die Output.log. Diese ist detaillierter und somit aussagekräftiger. Daher wäre diese Log wichtiger.
      Wichtig ist auch zu wissen dass eine Log bei jedem KSP-Start neu angelegt und die vorherige überschrieben wird.
      Alles Käse, oder was?
    • Okay hier habe ich die Logs.
      Ich habe also einfach das Spiel gestartet, bei der Datei Kerbins Space Program einmal auf "Load" geklickt und nachdem nichts passiert ist das Spiel beendet.
      Die größere der beiden output_log.txt Datein ist die aus der 64Bit Variante.
      Wäre nett wenn ihr euch die ansehen könntet, ich hoffe es ist etwas zu finden.
      Dateien
      • KSP.log

        (315,62 kB, 14 mal heruntergeladen, zuletzt: )
      • output_log.txt

        (663,21 kB, 7 mal heruntergeladen, zuletzt: )
      • output_log.txt

        (541,39 kB, 9 mal heruntergeladen, zuletzt: )

    • (Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)


      [GamePersistence Error]: No ROSTER node found in save state
      Grad bissl recherchiert. Die Meldung besagt dass da Teile der persistence.sfs fehlen. Das ist dein Savegame. Die Datei selbst ist dann nicht mehr zu reparieren. Einzige Möglichkeit wäre: Guck mal in deinem Savegame im ordner Backup ob du da noch eine persistence.sfs in etwa vom gleichen Zeitraum hast. Dann kannst du zumindest zu diesem Backup-Zeitpunkt wiederherstellen. Ansonsten ist dein Savegame hinüber.

      Sind auch noch ein paar andere Fehler in der Log. Gib mal bitte deine Hardwaredaten. Scheint nämlich so als wären da die Video-Einstellungen nicht korrekt oder deine Grafik würde da Probleme bereiten.
      Alles Käse, oder was?
    • Tatsächlich habe ich noch ein verstecktes Backup gefunden, mit dem es nach etwa rumprobieren wieder läuft. Der Verlust ist tragbar also soweit gut. Dafür das ich befürchtet hatte hunderte Spielstunden zu verlieren ist das ein gutes Ergebnis. Danke für eure Hilfe Thomas P. und vor allem Cheesecake, ihr habt mich wirklich vor der Verzweiflung gerettet.

      Hier sind trotzdem nochmal die Daten falls es noch wichtig ist. Schließlich soll es ja auch dauerhaft gut gehen jetzt.

      Hardware Specs:

      OS: Windows 10 1703 Build 15063.413 Creators Update

      CPU: Intel Core i5 3350P @3.1Ghz

      RAM: 12 GB

      Grafik GTX 750Ti